Upgrading To 1.3.0 From 1.2.*

Upgrading To 1.3.0 From 1.2.*

zCart 1.3.0 is a major release and contains breaking changes!

Please read the changelog for detail about the changes, this will help you to decide if you really need to upgrade or not.

Warning! You have to have command line access on your server to complete the upgradation.

 

TIPS! If you don’t have any real data and visitor we recommend to do a fresh installation.

 

To upgrade to the 1.3.0 from 1.2.* please follow these steps:

Step 1: Download the files and extract on your local computer.

Step 2: Set your marketplace in maintenance mode, so that visitor doesn’t get any errors or see sensitive system information.

Step 3:  Take a backup of your database and the project files(current running script). So that you can get back to the old version if having issues with the new one.

Step 4: Replace only these directories and files [Dont touch other files/directories] with the newly downloaded one:

Directories:

  1. app
  2. bootstrap
  3. config
  4. database
  5. public (Only if you use the default theme without any modification)
  6. resources
  7. routes
  8. vendor

Files:

  1. composer.json
  2. composer.lock
  3. package.json

Step 5: Check the permissions as described in the installation guide.

Step 6: Open the command line and cd into the project root. Then run this command:

php artisan migrate
php artisan db:seed --class=LanguagesSeeder
php artisan db:seed --class=TimezonesSeeder

Step 7: Now turn off the maintenance mode and you’re done.

 

HELP! If you got any issues please contact zCart support team with detail explanations and screenshots of the issues. The support team can help you fast it you provide every detail of the problem.

 

 zCart support team can help you to upgrade your system. Check All The Paid Services Here

 

Was this helpful to you?

Leave Comment